fehlende Paket für Asterisk 1.4 unter CentOS5 nachinstallieren

Da wir uns entschlossen haben, die von den Anrufern hinterlassenen Sprachnachrichten, neben der Definition der einzelnen Voicemailboxen, in einer MySQ_Datenbank zu speichern, benöltigen wir noch diverse Pakete, die unter umständen in der aktuellen installierten Version von CentOS5 nioch nicht vorliegen.

So überprüfen wir mit yum list PAKETNAME als erstes ob folgende Pakete installiert sind:

  • libtool-ltdl
  • libtool-ltdl-devel
  • unixODBC
  • unixODBC-devel
  • mysql-connector-odbc

Fehlen diese installieren wir die Pakete einfach via yum:

yum -y install libtool-ltdl libtool-ltdl-devel unixODBC unixODBC-devel mysql-connector-odbc

Nach Installation der mysql-connector-odbc passen wir die zugehörige Konfigurationsdatei /etc/odbcinst.ini an. Der Treibername ist von libmyodbc.so in libmyodbc3.so abzuändern.

Die vollständige Konfigurationsdatei lautet demnach:

# Driver from the MyODBC package
# Setup from the unixODBC package
[MySQL]
Description     = ODBC for MySQL
Driver          = /usr/lib/libmyodbc3.so
Setup           = /usr/lib/libodbcmyS.so
FileUsage       = 1

Zurück zum Inhaltsverzeichnis ⇒ asterisk

Cookies helfen bei der Bereitstellung von Inhalten. Durch die Nutzung dieser Seiten erklären Sie sich damit einverstanden, dass Cookies auf Ihrem Rechner gespeichert werden. Weitere Information
  • voip/asterisk/fehlende_pakete_nachinstallieren.txt
  • Zuletzt geändert: 20.04.2008 22:00.
  • (Externe Bearbeitung)